Mac下的MAMP Pro切换命令行下的PHP版本

前言

MAMP Pro 是Mac下的一款PHP集成开发环境,简单好用,支持多PHP版本共存。

设置命令行PHP版本

如上图,MAMP Pro可以设置命令行下的PHP版本,默认这样设置并保存后,然后到命令行执行命令:

  1. php -v

会发现并没有生效,那是因为MAMP把配置生成到了~/.profile文件中,我们需要在shell启动时加载一遍这个文件,PHP命令才能生效。
由于我的shell用的是ZSH,所以需要在配置文件~/.zshrc中加入:

  1. source ~/.profile

然后重启shell即可成效。